langchain==1.4.8
LangChain released v1.4.8 with dependency updates and issued a deprecation warning that Python 3.10 support will be dropped in langchain 1.5.0 and langchain-core 1.8.0.
原始内容为英文;当前页面提供中文导航与来源说明,具体事实请以原文为准。
为什么值得关注
LangChain version 1.4.8 has been released. The release issues an explicit warning stating that Python 3.10 support will be dropped in langchain 1.5.0 and langchain-core 1.8.0, urging users to upgrade to Python 3.11+. Changes include bumping langchain-core, updating multiple dependencies (such as fastmcp to 4.1.2, opentelemetry-api to 1.45.1, authlib to 1.9.1, joserfc to 1.7.6, and pyasn1 to 0.6.5), relaxing third-party dependency upper bounds, and addressing integration dependency patches.
可执行摘要
LangChain v1.4.8 published with multiple dependency bumps (including fastmcp, authlib, and joserfc) and a deprecation warning for Python 3.10 planned for langchain 1.5.0 / langchain-core 1.8.0.
- Agent 实用度
- 77/100
- 可信度
- 96%
- 机器格式
- JSON + Markdown
开发者应核对什么
- Prepare environments for upcoming deprecation by upgrading Python runtime to 3.11 or later ahead of langchain 1.5.0 and langchain-core 1.8.0.
- Update project dependencies to langchain==1.4.8 to incorporate recent dependency bumps and relaxed upper bounds.