Agent InfrastructureAutomated release watch

@cloudflare/worker-bundler@0.2.4

Cloudflare's @cloudflare/worker-bundler package updated its minimum smol-toml dependency to ^1.7.2 to resolve a high-severity denial of service vulnerability.

Human read

Why this signal matters

@cloudflare/worker-bundler version 0.2.4 addresses a security vulnerability by bumping the minimum required version of dependency smol-toml to ^1.7.2 . This update incorporates an upstream fix originally introduced in smol-toml 1.7.1 that resolves a high-severity denial of service (DoS) condition triggered by malformed TOML files.

Agent parse

Actionable summary

@cloudflare/worker-bundler@0.2.4 raises the dependency floor for smol-toml to ^1.7.2 , incorporating an upstream security fix (from 1.7.1) for a high-severity denial of service caused by malformed TOML input.

Agent usefulness
92/100
Confidence
96%
Canonical data
JSON + Markdown
Next actions

What builders should check

  • Upgrade @cloudflare/worker-bundler to version 0.2.4 or ensure smol-toml resolves to ^1.7.2 to mitigate the DoS vulnerability.
Classification

Tags and routing

cloudflareagents-sdkedge-runtime
Related signals

Continue the thread